You are using an unsupported browser. Please update your browser to the latest version on or before July 31, 2020.
close
Home > Getting Started > Getting Started with Glitch: Part 2 - The Project Options Menu & App Status Bar
Getting Started with Glitch: Part 2 - The Project Options Menu & App Status Bar
print icon

In this section of the Getting Started with Glitch Guide, we'll take a look at the Project Options menu and App Status bar, both of which can be found within the project editor.

 

The Project Options Menu

 

 

  • To see the Project Options menu, click the little down arrow next to the project name.  

  • By default, each project is given a name consisting of three -random-words.  To give your project a new name, click on the existing name and then start typing.

  • By default, each project is given a description that uses random words.  To give your project a new description, click on the existing description and start typing.

 

Here are some more things that you can do from the Project Options menu...

 

New Project

  • Click this button to create a new project.

 

Remix Project

  • Click this button to make a copy of the project that you are working on.

 

Switch Project

  • Click this button and a popup list of your existing projects will appear.  Click on one of these projects to open it in the project editor.

 

Boost This App

  • You will only see this button if you subscribe to Glitch Pro.  Clicking it will add extra powers to your project.

 

Embed This Project

  • Click this button to copy code that you can use to embed your project on another site.

 

Change Theme

  • Switches the project editor from “day mode” to an easier-on-the-eyes “dark mode”.

 

Refresh App on Changes

  • By default, the project editor will refresh the app as you edit the code.  If you don’t want this to happen, click the check box to disable this option.

 

Wrap Text

  • Enable this feature if you don’t want to scroll all the way to the right to see complete lines of code.

 

Keyboard Shortcuts

  • Click this button and a popup will appear showing you what keyboard shortcuts are available to use with the project editor.

 

Archive This Project

  • Is a “soft delete” feature that you can use to stop a project from running and from being edited.  If you change your mind, you can un-archive a project from your dashboard.

 

App Status

 

 

When you click the App Status button at the bottom of the file view in the project editor, you will see the following project stats:

  • Memory

  • Disk space

  • CPU

  • Boost status

 

If your project starts to exceed a technical restriction like disk space, the App Status green OK sign will turn to a red Warning sign.  In the Help Center, we offer several tips on how to manage disk space.  Click here to learn more.

 

In the last section of this Getting Started with Glitch Guide, we'll take a look at the Tools menu & Share menu.   Click here to continue.

Got more questions? Check out our Community Forum!
Open 24/7, the forum is where Glitch makers help each other and show off all the rad apps that they have created. It's the friendliest community of coders on the Web!
Feedback
0 out of 0 found this helpful

scroll to top icon